Problerma con Editor di Invision


Problerma con Editor di Invision

Messaggio Da Andy54 il Gio 18 Dic 2008 - 1:01

Ho creato il forum con INVISION ed ho davvero pochi problemi (anche perchè già gestisco un portale ed ho esperienza) ma c'è ne è uno che trovo grave perchè un forum è soprattutto scrittura ed il problema riguarda l'editor di Invision.
Ho il BBcode attivato e HTML disattivato nella finestra di composizione del testo: quando si seleziona una parola con il mouse e la si vuole associare ad un link, la stringa con il link viene incollata al termine del testo.
Eccone un esempio: questo link incollato alla fine del testo volevo che fosse un link abbinato alla parola "creato" [url]http://www.**29**.com[/url]

... niente da fare, quasiasi parola selezioni per abbinargli un link lo stesso viene sempre posizionato a fondo testo. La stringa non viene incollata neppure in prossimità di un punto del testo selezionato con il mouse ma sempre e solo sotto.

Credo sia una cosa davvero scomoda per chi scrive non poter inserire un link dove vuole e come vuole; si è costretti a copiare la stringa con il link messa sotto, cancellarla da quella posizione, incollarla dove la si vuole e sostituire a mano l'indirizzo del link compreso dopo la ] e prima della [/ con il testo che si voleva trasformare in link.

I tecnici possono rimediare?
avatar
Andy54
Sono un nuovo membro :)

Messaggi : 15

Vedi il profilo dell'utente http://ju29roteam.forumattivo.com/forum.htm
Andy54 è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Mirna il Gio 18 Dic 2008 - 9:38

Strano io uso invision ed ecco il risultato

Forum di Supporto

Funziona perfettamente Very Happy
avatar
Mirna
Veterano dello staff

Sesso : Femminile
Età : 49
Messaggi : 2343
Località : Bodio-Svizzera


Vedi il profilo dell'utente http://ticino.forumattivo.it/
Mirna è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Andy54 il Gio 18 Dic 2008 - 10:53

Ciao Mirna, ho visto il tuo forum con Invision e vedo, dall'esempio che mi hai fatto, che per te tutto va bene.
Non saprei che dire .. ho fatto tutte le prove possibili sia con IE6 che con Firefox e tutto resta uguale per me.
Ho provato anche ad abilitare l'HTML nella finestra dell'Editor, ma nulla.

Ti dirò di più: anche utilizzando questo forum di aiuto se io scrivo la frase "Questa è una prova di link" ed intendo associare un link alla parola PROVA mi succede che, selezionando la parola prova ed inserendo l'indirizzo del link, questo mi viene incollato alla fine della frase se uso solo il BBcode ed, invece, all'inizio della frase se abilito anche l'HTML.
Ecco il risultato utilizzando l'editor di questo forum:
Questa è una prova di linkhttp://www.forumattivo.com

Tu che impostazioni hai scelto per l'Editor? (per valutare perchè tu sopra sei riuscita a scrivere un link come io vorrei fare)
avatar
Andy54
Sono un nuovo membro :)

Messaggi : 15

Vedi il profilo dell'utente http://ju29roteam.forumattivo.com/forum.htm
Andy54 è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Mirna il Gio 18 Dic 2008 - 13:14

Allora vediamo se riesco a spiegarti bene perchè oggi fatico a mettere screen mahh............provero a parole

Allora esempio:

scrivo ciao come stai .....vorrei nettere la parolina "io" linkata al mio forum ad esempio allora se per caso scrivi tramite risposta rapida sopra ci sono delle immaginine per il testo le prime 3,per il quote per il codice poi trovi per hostare un immagine e per inserire tramite link un'immagine subito a finco vedi un disegnino che sembra una catena ecco clicca li poi vedrai due linnee una per il link e l'altra per il testo in questo momento allora che fai...........metti il link che desideri e nella seconda invece scrivi io e ok ecco la parolina io linkata dove volevo provaci .

Spero mi sono spiegata anche a parole gli screen oggi mi creano problemi fammi sapere
avatar
Mirna
Veterano dello staff

Sesso : Femminile
Età : 49
Messaggi : 2343
Località : Bodio-Svizzera


Vedi il profilo dell'utente http://ticino.forumattivo.it/
Mirna è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Andy54 il Gio 18 Dic 2008 - 14:04

Grazie Mirna della pazienza. Quello che dici sei riuscita a spiegarlo bene anche senza screen. Così come l'hai spiegato tu riusciva anche a me ma riesce solo se tu inserisci il link mentre scrivi il testo. La difficoltà che io ho trovato è se vuoi inserire il link dopo che hai scritto anche un testo lungo.
Spesso dopo aver scritto un testo lungo vuoi prendere una parola (diciamo, per esempio, la ventesima su 40 parole) del testo e collegarci un link che rimandi ad altra pagina: è in quel caso che ti incolla il link alla fine di tutto il lungo testo.
Fai una prova e vedrai che dovrebbe fare lo stesso anche a te: scrivi un post lungo, poi prendi la seconda parola e cerca di collegarci un link. Vedrai che il link viene incollato alla fine del testo del post.

Ho una grande abitudine ad usare dei forum basati su Invision 2.1 e 2.3 e funzionano diversamente: tu puoi prendere qualsiasi parola di un testo, anche lungo e collegare ad una qualsiasi parola un link, oppure puoi inserire un link in qualsiasi punto del testo (cosa che qui non riesce ... prova a scrivere prima un testo di 4 parole e poi ad inserire un link dopo la prima parola ... incolla il link solo dopo la quarta parola).
Anche con la vecchia versione 1.3 di Invision, che avevamo su un altro forum free, si riusciva a fare quello che ti ho descritto e che faccio abitualmente, da utente, su forum con le versioni a pagamento di Invision.
avatar
Andy54
Sono un nuovo membro :)

Messaggi : 15

Vedi il profilo dell'utente http://ju29roteam.forumattivo.com/forum.htm
Andy54 è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Mirna il Gio 18 Dic 2008 - 14:13

dovrei provare vedro questa sera ora non ho molto tempo ,comunque di solito so subito quale parola voglio linkare e lo faccio subito forse per questo non l'ho mai notato questa sera provero ma non è grave se cosi fosse vedro di segnalarlo caso mai Very Happy
avatar
Mirna
Veterano dello staff

Sesso : Femminile
Età : 49
Messaggi : 2343
Località : Bodio-Svizzera


Vedi il profilo dell'utente http://ticino.forumattivo.it/
Mirna è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Andy54 il Mar 23 Dic 2008 - 10:52

Mirna scusami: nessuna novità, prova o segnalazione allo staff tecnico?

Auguri di buone feste a tutti.
avatar
Andy54
Sono un nuovo membro :)

Messaggi : 15

Vedi il profilo dell'utente http://ju29roteam.forumattivo.com/forum.htm
Andy54 è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da SUPER KONG POWER il Mar 23 Dic 2008 - 14:39

prova ad attivare l'html e quando vuoi collegare un link ad un testo:

[URL=link]testo[/URL]

Codice:
[URL="link"]"testo"[/URL]

per attivare l'html vai:

pannello d'amministrazione --> generale --> messaggi ed email

fammi sapere
in alternativa passa a phpbb3


ah m'ero scordato, buon Natale e buone vacanze Laughing
avatar
SUPER KONG POWER
**
**

Messaggi : 62

Vedi il profilo dell'utente http://consolemaster.forumattivo.com
SUPER KONG POWER è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Andy54 il Mar 23 Dic 2008 - 20:11

Ciao Super Kong, come ho scritto anche sopra non cambia nulla neppure abilitando l'HTML.
Mi consigli di passare al PHPbb3 ma credo sia quello che usa questo forum ed il problema è identico: io non ho la necessità di inserire il link mentre scrivo ma spesso dopo aver scritto un lungo articolo ed aver trovato su Google le pagine da linkare associandole ad una parola del testo (anche nella posizione alta dell'articolo).
Ho fatto la prova anche in questo stesso post cercando di associare il link di Forumattivo selezionando la parola PHPbb3 scritta sopra.
http://www.forumattivo.com

.... come vedi mi ha incollato il link solo alla fine del testo.
Se questo forum è realizzato in PHPbb3 il problema rimane ed è comune ad Invision. Auguri.
avatar
Andy54
Sono un nuovo membro :)

Messaggi : 15

Vedi il profilo dell'utente http://ju29roteam.forumattivo.com/forum.htm
Andy54 è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Ospite il Mar 23 Dic 2008 - 23:22

Mi consigli di passare al PHPbb3 ma credo che sia quello che usa....... Shocked

Ospite
Ospite


Ospite è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Ospite il Mar 23 Dic 2008 - 23:31

Spesso dopo aver scritto un testo lungo vuoi prendere una parola (diciamo, per esempio, la ventesima su 40 parole) del testo e collegarci un Link che rimandi ad altra pagina: è in quel caso che ti incolla il link alla fine di tutto il lungo testo.
Fai una prova e vedrai che dovrebbe fare lo stesso anche a te: scrivi un post lungo, poi prendi la seconda parola e cerca di collegarci un link. Vedrai che il link viene incollato alla fine del testo del post.
Shocked Shocked

Ospite
Ospite


Ospite è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Mirna il Mer 24 Dic 2008 - 13:22

Hai già scritto questo per favore non serve riscriverlo Very Happy

Bhe ho provato e hai ragione ma non lo ritengo un problema se so già quale parola linkare di solito io lo faccio pure ma puoi inserire il tuo suggerimento nel supporto potrebbe essere preso in considerazione per il futuro Very Happy
avatar
Mirna
Veterano dello staff

Sesso : Femminile
Età : 49
Messaggi : 2343
Località : Bodio-Svizzera


Vedi il profilo dell'utente http://ticino.forumattivo.it/
Mirna è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da SUPER KONG POWER il Mer 24 Dic 2008 - 19:50

siiiiiiiiiiiiiiiiiiiiiii ho capito finalmente!!!!!


a tutti fa così, in + se lo scrivi vieni ribaltato in alto.


fortunatamente ho trovato una soluzione, basta attivare il wysiwyg

What You See Is What You Get, in italiano: "Quello che vedi è quello che ottieni".


per attivarlo:

pannello --> generale --> messaggi ed email --> Attivare il modo WYSIWIG nei messaggi --> SI


ecco qui. il wysiwyg da qualche problema con i codici di youtube...
beh, parecchi, ma ne vale davvero la pena.

buon natale xD
avatar
SUPER KONG POWER
**
**

Messaggi : 62

Vedi il profilo dell'utente http://consolemaster.forumattivo.com
SUPER KONG POWER è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Andy54 il Gio 25 Dic 2008 - 22:23

Grazie Super Kong per esserti dedicato al problema, proverò quanto suggerisci anche se l'ideale sarebbe non dover fare delle sottrazioni, cioè avere una cosa a posto ma rimetterci negli inserimenti dei video di YouTube.
Buon Natale a te e a tutti gli amici di forumattivo.

PS: nelle prove che ho fatto, fino ad ora, non ho riscontrato problemi nell'inserimento dei video di YouTube.
avatar
Andy54
Sono un nuovo membro :)

Messaggi : 15

Vedi il profilo dell'utente http://ju29roteam.forumattivo.com/forum.htm
Andy54 è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da the crow il Ven 26 Dic 2008 - 0:11

@Andy54 ha scritto:Ecco il risultato utilizzando l'editor di questo forum:
Questa è una prova di linkhttp://www.forumattivo.com
Scusa ma nell'esempio citato sopra il tag per quello che vuoi portare per esempio e' errato, o meglio e giusto come e' inserito e come si vede visto che ci sono due 2 url e manca la parola prova tra i "tag":
Codice:
Questa è una prova di link[url=  http://www.forumattivo.com]http://www.forumattivo.com  [/url]
l'esempio giusto e' cosi
Codice:
 Questa è una [url= http://www.google.it/] prova [/url] di link
Questa è una prova di link
detto questo.. nn riesco a capire come fa l'url del link a finire in fondo al testo, forse dipende soltanto da come si inserisce il tag ..bohh!! ..ora smanetto un attimo sul mio pannello e vedo se trovo qualcosa. buon natale
avatar
the crow
Veterano dello staff

Sesso : Maschile
Età : 26
Messaggi : 8797
Località : Roma


Vedi il profilo dell'utente http://aiuto.forumattivo.it/forum
the crow è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da SUPER KONG POWER il Ven 26 Dic 2008 - 9:14

prova anche tu a scrivere un frase così.

sotto ne scrivi un altra.

ora clicca sul punto della prima frase e premi una faccina.

poi riprova premendo il pulsante per i link affianco all'immagine.

appare tutto in fondo al testo. fortunatamente il wysiwyg risolve il problema... io l'ho attivato anche per questo. happy
avatar
SUPER KONG POWER
**
**

Messaggi : 62

Vedi il profilo dell'utente http://consolemaster.forumattivo.com
SUPER KONG POWER è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Mirna il Ven 26 Dic 2008 - 9:35

Mah............. io ce l'ho attivato da sempre ma il problema persiste ...................
avatar
Mirna
Veterano dello staff

Sesso : Femminile
Età : 49
Messaggi : 2343
Località : Bodio-Svizzera


Vedi il profilo dell'utente http://ticino.forumattivo.it/
Mirna è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da the crow il Ven 26 Dic 2008 - 19:26

Ragazzi ho smanettato un po da per tutto nei due pannelli di controllo nn ho trovato (oppure nn l'ho visto) niente...comunque quello che vuol fare lei evideziare un testo e collegarlo a un link oltre che farlo a mano lo puo fare con un "collegamento ipertestuale"...purtroppo nel pannello dei messaggi nn c'e l'opzione
avatar
the crow
Veterano dello staff

Sesso : Maschile
Età : 26
Messaggi : 8797
Località : Roma


Vedi il profilo dell'utente http://aiuto.forumattivo.it/forum
the crow è stato ringraziato dall'autore di questo topic.

Re: Problerma con Editor di Invision

Messaggio Da Andy54 il Sab 27 Dic 2008 - 13:07

Il problema si risolve, in effetti, solo abilitando il wysiwyg che, per quanto provato fino ad ora, genera un altro problema: se incollate in un post un articolo prelevato da un giornale, o altra fonte, viene inserito in codice HTML con una formattazione "a caso" per quanto riguarda gli "a capo" (non segue neppure il codice html della fonte). In pratica vedrete il testo composto in una colonna più stretta dello spazio del forum.

L'unico compromesso provato che risolve il problema è questo:
usare il wysiwyg ma se si deve incollare del testo prelevato da altra fonte, prima di farlo, si deve cliccare sull'icona A/A che compare di colore rosa. Dopo cliccata la finestra Editor prende il codice come BBcode e incolla con la formattazione a tutta pagina del vostro forum.
avatar
Andy54
Sono un nuovo membro :)

Messaggi : 15

Vedi il profilo dell'utente http://ju29roteam.forumattivo.com/forum.htm
Andy54 è stato ringraziato dall'autore di questo topic.

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto

- Argomenti simili

 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum