SSL su dominio esterno aruba


Risolto SSL su dominio esterno aruba

Messaggio Da Atex96 il Sab 4 Lug 2020 - 17:27

Salve a tutti e scusate in anticipo se mi capiterà di infrangere qualche regola del forum (non ho ancora letto i regolamenti, lo farò subito dopo aver scritto questo post).

Vi scrivo perché, come da titolo, ho un problema con il certificato SSL sul mio forum dopo averlo collegato al dominio esterno (acquistato su aruba) via record CNAME.

Accendendo al forum dal dominio acquistato ricevo un avvertimento (quello solito quando non è installato alcun certificato per l'HTTPS). Se entro dal dominio di terzo livello (mioforum.forumattivo.com), invece, non ci sono problemi.

Qualcuno sa come posso risolvere?


Ultima modifica di Atex96 il Gio 6 Ago 2020 - 2:35, modificato 1 volta
Atex96
Atex96
Nuovo membro

Sesso : Maschio
Età : 24
Messaggi : 8
Località : Sant'Antimo


https://oceancityroleplay.forumattivo.com/
Atex96 è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da MattiaDes il Dom 5 Lug 2020 - 11:21

Buongiorno, quando hai aggiunto il dominio esterno al forum avevi già installato un certificato SSL, giusto?

In questo caso il certificato SSL installato include solo l'URL di base del forum e non il nuovo dominio esterno, per questo motivo si verifica l'errore.

Bisogna attendere che venga generato un nuovo certificato che includa il dominio esterno, affinchè l'indirizzo originale del forum sia protetto su entrambi gli indirizzi.

Prova ad attendere qualche giorno, nel caso in cui il nuovo certificato non dovesse essere generato proverò a sollecitare i tecnici happy


SSL su dominio esterno aruba Z_user10

SSL su dominio esterno aruba 1300 SSL su dominio esterno aruba 2203 SSL su dominio esterno aruba 392
MattiaDes
MattiaDes
Amministratore
Amministratore

Sesso : Maschio
Età : 24
Messaggi : 4449
Località : Italy


http://www.habbolifeforum.com
MattiaDes è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da Atex96 il Lun 6 Lug 2020 - 1:13

Ti ringrazio @MattiaDes aspetterò qualche giorno e vi aggiornerò. Intanto ho anche un altro dubbio.

Come ho detto ho reindirizzato su aruba, via CNAME, al mio forum. Oltre al problema del SSL ho notato che riesco ad accedere al forum solo se digito "https://www.mioforum.it"... non riesco invece ad accedere se digito solo "https://mioforum.it".

C'è un modo per reindirizzare anche la versione senza "www"?

Nel pannello aruba, alla sezione CNAME ho solo due campi:

- Nome Host: dove ho inserito "www" (e viene automaticamente completato con ".mioforum.it")
- Nome CNAME: dove ho inserito l'indirizzo del mio forum forumattivo

La versione senza "www" come ho detto, non viene reindirizzata in questo modo. Lascio uno screenshot per chiarire meglio.

SSL su dominio esterno aruba Screen10
Atex96
Atex96
Nuovo membro

Sesso : Maschio
Età : 24
Messaggi : 8
Località : Sant'Antimo


https://oceancityroleplay.forumattivo.com/
Atex96 è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da MattiaDes il Mar 7 Lug 2020 - 0:13

Per l'HTTPS mi risulta risolto, confermi? Very Happy

Per il secondo problema non saprei dirti, dato che è da molto tempo che non uso Aruba... in "Nome CNAM" l'URL di base del forum lo hai inserito senza http://www.?


SSL su dominio esterno aruba Z_user10

SSL su dominio esterno aruba 1300 SSL su dominio esterno aruba 2203 SSL su dominio esterno aruba 392
MattiaDes
MattiaDes
Amministratore
Amministratore

Sesso : Maschio
Età : 24
Messaggi : 4449
Località : Italy


http://www.habbolifeforum.com
MattiaDes è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da Atex96 il Mar 7 Lug 2020 - 3:15

Ho potuto controllare solo adesso, tutto funzionante, ti ringrazio per la risposta.

Per quanto riguarda il problema del "www" non riesco proprio a capire perché non funzioni.

Su Aruba, nel campo "HOST" ho inserito solo "www" (Non potevo lasciarlo vuoto) e nel campo "CNAME" ho inserito solo il link forumattivo senza "www".

Possibile che nel campo "HOST" vada inserito un carattere speciale che vale come un carattere vuoto? Ho provato, ad esempio, con "@" ma ricevo l'errore "Fornire un host alfanumerico"... (Non so se mi sono spiegato).

Ti ringrazio ancora per la disponibilità @MattiaDes
Atex96
Atex96
Nuovo membro

Sesso : Maschio
Età : 24
Messaggi : 8
Località : Sant'Antimo


https://oceancityroleplay.forumattivo.com/
Atex96 è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da MattiaDes il Mar 7 Lug 2020 - 19:26

È strano, non so da cosa possa dipendere... Hai provato a sentire da Aruba?

Il file htaccess del dominio riesci a modificarlo? Se sì, potresti provare a metterci questo codice:

Codice:
RewriteEngine on
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]


SSL su dominio esterno aruba Z_user10

SSL su dominio esterno aruba 1300 SSL su dominio esterno aruba 2203 SSL su dominio esterno aruba 392
MattiaDes
MattiaDes
Amministratore
Amministratore

Sesso : Maschio
Età : 24
Messaggi : 4449
Località : Italy


http://www.habbolifeforum.com
MattiaDes è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da Atex96 il Mer 8 Lug 2020 - 15:21

Non credo che la gestione DNS di Aruba comprenda anche la modifica del file htaccess. Da quanto mi hanno detto (li ho già contattati) non dipende da loro, ecco perché ho chiesto qui.

Mi sta mandando fuori di testa questa cosa, le persone non sono più abituate ad integrare il "www" in un link. Mi sa che dovrò farmene una ragione...
Atex96
Atex96
Nuovo membro

Sesso : Maschio
Età : 24
Messaggi : 8
Località : Sant'Antimo


https://oceancityroleplay.forumattivo.com/
Atex96 è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da MattiaDes il Ven 10 Lug 2020 - 9:08

La cosa strana è che http://oceancityroleplay.it funziona, quindi magari è il certificato SSL che lo manda in confusione

Il link nel campo CNAME lo hai inserito senza http e https?

Comunque a me il link senza nulla: oceancityroleplay.it lo apre

Solo https://oceancityroleplay.it non funziona


SSL su dominio esterno aruba Z_user10

SSL su dominio esterno aruba 1300 SSL su dominio esterno aruba 2203 SSL su dominio esterno aruba 392
MattiaDes
MattiaDes
Amministratore
Amministratore

Sesso : Maschio
Età : 24
Messaggi : 4449
Località : Italy


http://www.habbolifeforum.com
MattiaDes è stato ringraziato dall'autore di questo topic.

Risolto Re: SSL su dominio esterno aruba

Messaggio Da Atex96 il Mar 14 Lug 2020 - 15:24

Ciao @MattiaDes, scusa se rispondo solo ora, sono stato un po' impegnato. Personalmente non mi funziona nessuno dei due link, devo immettere obbligatoriamente anche "www" per farli funzionare.

Su aruba, nel campo CNAME, non ho inserito http e https (ho inserito solo "oceancityroleplay.forumattivo.com")

Non riesco davvero a capacitarmi di questa cosa, è la prima volta che assisto a questa problematica.
Atex96
Atex96
Nuovo membro

Sesso : Maschio
Età : 24
Messaggi : 8
Località : Sant'Antimo


https://oceancityroleplay.forumattivo.com/
Atex96 è stato ringraziato dall'autore di questo topic.

Vedere l'argomento precedente Vedere l'argomento seguente Torna in alto


 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum